大智慧真实突破主图指标公式


  牛熊界:MA(CLOSE,49),LINETHICK2,colorWHITE;

  SSL:=EMA(CLOSE,3);

  MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);

  MM:=(IF(((DATATYPE 》 5) AND (DATATYPE 《 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );

  SA:=(MM * 0.985);

  {www.gupang.com 股旁网_大智慧必赢亚洲线上娱乐指标公式}

  短趋势:IF(((SSL 》 MM)),SSL,SA),LINETHICK1,colorwhite;

  空方:IF(((SSL 》 MM) ),MM,SA),LINETHICK1,colorFFFFFF;

  多方:IF(((SSL 》 MM)),MM,SA),LINETHICK2,colorFF00FF;

  VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);

  VAR4Y:=REF(CLOSE,1);

  VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);

  VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);

  VAR9Y:=SMA(VAR8Y,3,1);

  VARAY:=SMA(VAR9Y,3,1);

  DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y 》 5)) ),(HIGH * 1.0099),5),colorFFFFFF;

  X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);

  Y:=EMA(CLOSE,10);

  LL:=REF(CLOSE,2);

  MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);

  DB:=IF(((MM 《 REF(MM,1)) AND (MM 》 79)),MM,0);

  DRAWICON(CROSS(Y,X),(LOW * 0.985),1),LINETHICK3,colorred;

  DRAWICON(CROSS(X,Y),(HIGH * 1.02),2),LINETHICK2,color00ff00;

  DRAWTEXT(DB,(HIGH * 1.02),‘↓顶’),LINETHICK2,color00ff00;

  VAR1:=LLV(LOW,21);

  VAR2:=HHV(HIGH,21);

  AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

  AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

  VAR3:=LLV(LOW,55);

  VAR4:=HHV(HIGH,34);

  VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);

  VAR6:=((AK + VAR5) / 2);

  VAR8:=EMA(VAR6,5);

  BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);

  AB:=CROSS(AK1,AK);

  BB1:=(CROSS(AK1,BB) AND (BB 《 30));

  CD:=(BB1 * 0.6);

  DRAWTEXT((CD = 0.6),(LOW * 0.99),‘↑底2’),LINETHICK1,color33CC99;

  DRAWTEXT((AB = 1),(LOW * 0.99),‘↑底1’),LINETHICK1,colorwhite;

  c1:=(CLOSE+LOW+HIGH)/3;

  c2:=EMA(c1,6);

  c3:=EMA(c2,5);

  c4:=CROSS(c2,c3);

  DRAWTEXT(c4,LOW/1.01,‘★’),LINETHICK3,COLORRED;

  c5:=CROSS(c3,c2);

  DRAWTEXT(c5,HIGH*1.03,‘★’),LINETHICK3,COLORBLUE;

相关信息