大智慧伦伦主图指标公式


  LL1:=(HIGH + LOW + CLOSE)/3;

  DRAWTEXT((C-REF(C,1))/REF(C,1)*100》9.5,OPEN,‘涨停’+‘ ’+STR(YEAR)+STR(MONTH)+STR(DAY)+STR(TIME)),COLOR00FFFF;

  DRAWTEXTREL(1,10,‘■所属板块:’+BKNAME),COLORGREEN;

  DRAWTEXTREL(1,50,‘■主题库:’+SELFSTRING(‘主题投资’)),COLORYELLOW;

  {DRAWTEXTREL(1,90,‘■主营构成:’+SELFSTRING(‘主营构成’)),COLORYELLOW; }

  DRAWTEXTREL(1,90,‘■主营业务:’+SELFSTRING(‘主营业务’)),COLORYELLOW;

  DRAWTEXTREL(1,130,‘■智能诊断:’+SELFSTRING(‘智能诊断’)),COLORYELLOW;

  DRAWTEXTREL(1,170,‘■千股千评:’+SELFSTRING(‘千股千评’)),COLORYELLOW;

  DRAWTEXTREL(1,210,‘■敢死队席位:’+SELFSTRING(‘敢死队席位’)),COLORYELLOW;

  MA5:EMA(LL1,5),colorwhite;

  MA10:EMA(LL1,10);

  MA30:EMA(LL1,30);

  T:=TIMETOT0(CURRENTTIME)/60;

  交易日:=IF(CURRENTDATE=DATE,1,0);

  交易时间:=IF(交易日=1 AND CURRENTTIME》=93000 AND CURRENTTIME《150000 AND DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,

  IF(CURRENTTIME《113000,(T-570),IF(CURRENTTIME》130000,(T-660),120)),240);

  虚拟量:=VOL*240/交易时间;

  LL2:=cross(c,MA30) and cross(c,MA5) and cross(c,MA10);

  DRAWICON(LL2 ,L,7),align1;

  LL3:=MA30》=ref(MA30,1) and cross(c,ma30) and MA5》=ref(MA5,1) and MA10》=ref(MA10,1) and MA10》=ref(MA10,1) and 虚拟量》ma(vol,5) and 虚拟量》ma(vol,10) and 虚拟量》ma(vol,20);

  STICKLINE(LL3,c,O, 8,0),COLOR111187;

  STICKLINE(LL3,c,O, 6,0),COLOR1111A7;

  STICKLINE(LL3,c,O, 4,0),COLOR1111C7;

  STICKLINE(LL3,c,O, 2,0),COLOR1111E7;

  STICKLINE(LL3,c,O,0.2,-100),COLOR4444FF;

  partline(MA30,MA30》=ref(MA30,1),rgb(255,0,0),MA30《ref(MA30,1),rgb(0,255,0)),linethick2;

  {www.gupang.com 股旁网_大智慧指标公式}

  ;现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),colorwhite,POINTDOT;

  I1:=0;

  flag1:=0;

  while I1《BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)

  DO

  IF REF(H,I1)《REF(L,I1+1) AND REF(L,I1+1)》HHV(H,I1+1)

  THEN BEGIN FLAG1:=1;

  S1:=I1;

  I1:=BARSLAST(DISPSTATUS=1);

  END

  ELSE I1:=I1+1;

  STICKLINE(FLAG1,REF(L,S1+1),HHV(H,S1+1),(s1+1)*20,0),Color808080,ALIGN1,LAYER7;

  DRAWTEXT(flag1,REF(L,s1+1),NUMTOSTRN(ref(l,s1+1),2)+‘-’+NUMTOSTRN(hhV(h,S1+1),2)),ALIGN2,COLORffffff,linethick2;

  I:=0;

  flag:=0;

  while I《BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)

  DO

  IF REF(L,I)》REF(H,I+1) AND REF(H,I+1)《LLV(LOW,I+1)

  THEN BEGIN FLAG:=1;

  S:=I;

  I:=BARSLAST(DISPSTATUS=1);

  END

  ELSE I:=I+1;

  STICKLINE(FLAG,REF(h,S+1),LLV(L,S+1),20*(s+1),500),Color808080,ALIGN1,LAYER7;

  DRAWTEXT(FLAG,REF(H,s+1),NUMTOSTRN(ref(h,s+1),2)+‘-’+NUMTOSTRN(LLV(L,S+1),2)),ALIGN2,COLORgreen,linethick2;

相关信息