大智慧超级无敌BOLL主图指标公式


  N:=20;P:=3;

  BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

  DWN:BBI-P*STD(BBI,N),LINETHICK2;

  UPR:BBI+P*STD(BBI,N),LINETHICK2;

  MA5:MA(c,5),COLORFF50FF,LINETHICK2;

  partline(MA5,MA5》=ref(MA5,1),RGB(255,0,0),MA5《ref(MA5,1),RGB(0,250,0)),LINETHICK3;

  DRAWutf-8LAST(MA5》=ref(MA5,1),STRIP(RGB(0,150,0),RGB(150,0,0),1));

  DRAWutf-8LAST(MA5《=ref(MA5,1),STRIP(RGB(150,0,0),RGB(0,150,0),1));

  VAR326:=IF(CLOSE》ref(CLOSE,1),88,0);

  VAR327:=IF(CLOSE/ref(CLOSE,1)》1.050 AND HIGH/CLOSE《1.010 AND VAR326》0, 91, 0);

  DRAWTEXT(VAR327》90,LOW*0.99,‘追’),COLORYELLOW;

  STICKLINE(VAR327》90,OPEN,CLOSE,3,0),COLORYELLOW;

  STICKLINE(VAR327》90,LOW,HIGH,0,0 ),COLORYELLOW;

  {45度异动}

  x1:=(C+L+H)/3;

  bb13:=atan(eMA(x1,13)-ref(eMA(x1,13),1))*3.1416*10;

  eMA8:=eMA(c,8);

  DRAWTEXT(filter(bb13》1 and eMA(x1,13)》ref(eMA(x1,8),1),10),

  eMA8,‘∠45上升’),coloryelLOW;

  AAA:=(3*C+H+L+O)/6;

  VAR41:=(8*AAA+7*ref(AAA,1)+6*ref(AAA,2)+5*ref(AAA,3)+4*ref(AAA,4)+3*ref(AAA,5)+2*ref(AAA,6)+ref(AAA,8))/36;

  TJ1:=VOL=HHV(VOL,10) AND VOL》2*ref(VOL,1) AND CLOSE》VAR41;

  立桩量:=FILTER(TJ1,5);

  TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE》ref(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE》ref(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE》ref(HIGH,3),1,0)));

  突破:=TJ2=1;

  TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE》ref(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE》ref(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE》ref(LOW,3),1,0)));

  三天法则:=TJ3=1;

  成立:=三天法则 AND 突破;

  条件成立:=FILTER(成立,3);

  DRAWTEXT(条件成立,L*0.99,‘立桩量’),COLORYELLOW;

  var1:=CLOSE》ref(CLOSE,1) AND CLOSE》ref(CLOSE,2);

  var2:=ref(var1,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var3:=ref(var2,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var4:=ref(var3,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var5:=ref(var4,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var6:=ref(var5,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var7:=ref(var6,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var8:=ref(var7,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var9:=ref(var8,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  varA:=ref(var9,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  varB:=ref(varA,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  varC:=ref(varB,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  varD:=CLOSE《ref(CLOSE,1) AND CLOSE《ref(CLOSE,2);

  varE:=ref(varD,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  varF:=ref(varE,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var10:=ref(varF,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var11:=ref(var10,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var12:=ref(var11,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var13:=ref(var12,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var14:=ref(var13,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var15:=ref(var14,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var16:=ref(var15,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var17:=ref(var16,1) AND CLOSE《=ref(CLOSE,1) AND CLOSE》=ref(CLOSE,2);

  var18:=ref(var17,1) AND CLOSE》=ref(CLOSE,1) AND CLOSE《=ref(CLOSE,2);

  var19:=ref(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

  var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;

  var1A:=ref(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

  var8 OR var9 OR varA OR varB OR varC,1) AND varD;

  STICKLINE(var19,ref(CLOSE,1),ref(CLOSE,2),8,0),COLOR00FFFF;{黄色}

  STICKLINE(var1A,ref(CLOSE,1),ref(CLOSE,2),8,0),COLORFF00FF;{粉红色}

  黄底买入:var19,LINETHICK0,COLOR00ffff;

  粉顶卖出:var1A,LINETHICK0,COLORFF50FF; {本文来至CXH99.COM}

  红色持股:0,LINETHICK0,COLORRED;

  绿色持币:0,LINETHICK0,COLOR00d900;

  DRAWICON(var19,ref(CLOSE,1)*0.99,7),ALIGN1;

  DRAWICON(var1A,ref(CLOSE,1)*1.02,8),ALIGN1;

  DRAWTEXTABS(2,5,‘所属板块:’+BKNAME),COLORFF50FF,LINETHICK1;

  流通盘大小:=FINANCE2(37)/1000000*100;

  DRAWTEXTABS(2,20,‘流通盘大小:’+NUMTOSTRN(流通盘大小,2)+‘亿’+‘ 电子盲制作’),LINETHICK1,COLORRED;

  每股收益:=FINANCE2(3);

  每股市盈率:=DYNAINFO(39);

  每股净资产:=FINANCE2(4);

  销售毛利率:=FINANCE2(12);

  主营收入同比:=FINANCE2(11);

  净利润同比增长:=FINANCE2(10);

  DRAWTEXTABS(160,35,‘每股收益:’+NUMTOSTRN(每股收益,2)+‘元’),COLOR00FF00;

  DRAWTEXTABS(160,50,‘每股市盈率:’+NUMTOSTRN(每股市盈率,1)+‘倍’),COLORRED;

  DRAWTEXTABS(160,65,‘每股净资产:’+NUMTOSTRN(每股净资产,2)+‘元’),COLORRED;

  DRAWTEXTABS(2,35,‘销售毛利率:’+NUMTOSTRN(销售毛利率,2)+‘%’),LINETHICK1,COLOR00FF00;

  DRAWTEXTABS(2,50,‘主营收入同比增长:’+NUMTOSTRN(主营收入同比,2)+‘%’),LINETHICK1,ColorYELLOW;

  DRAWTEXTABS(2,65,‘净利润同比增长:’+NUMTOSTRN(净利润同比增长,2)+‘%’),LINETHICK1,COLOR00FF00;

  DRAWTEXTABS(3,80,‘历史最高价:’+HHV(HIGH,0)),Colorred;

  DRAWTEXTABS(3,95,‘历史最低价:’+LLV(LOW,0)),ColorAFFF00;

  A4:=MA(CLOSE,20);

  A5:=(CLOSE 》 MA(CLOSE,5));

  A6:=(MA(CLOSE,5) 》 MA(CLOSE,10));

  A7:=(CLOSE 》 MA(CLOSE,10));

  A8:=(MA(CLOSE,5) 》 MA(CLOSE,20));

  A9:=(CLOSE 》 MA(CLOSE,20));

  A10:=ref(A4,1);

  A11:=(A4 》 A10);

  AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));

  DSLX:=(CLOSE / INDEXC);

  DSLX1:=MA(DSLX,5);

  DSLX2:=MA(DSLX,10);

  V1:=MA(VOL,5);

  V2:=MA(VOL,10);

  阻力位:=IF((CLOSE 》 200),(CLOSE * 1.01),(CLOSE * 1.07));

  阻力位1:=IF((CLOSE 《 10),(CLOSE * 1.05),阻力位);

  止损位:=IF((CLOSE 》 200),(CLOSE * 0.99),(CLOSE * 0.93));

  止损位1:=IF((CLOSE 《 10),(CLOSE * 0.95),止损位);

  TJTS1:=BARSTATUS=2 and c《200;

  TJTS2:=BARSTATUS=2 and c》200;

  k2:=HHV(h,BARSLAST(DISPSTATUS=1)+1);

  DRAWTEXT(TJTS1 and((CROSS(AVX,1) AND (V1 》= V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 ’),ALIGN2,colorDC143C;

  DRAWTEXT(TJTS1 and((CROSS(AVX,1) AND (V1 《 V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 ’),ALIGN2,colorDC143C;

  DRAWTEXT(TJTS1 and((CROSS(AVX,1) AND (V1 》 V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股量价配合良好,但相对其它必赢亚洲线上娱乐并没有明显走强,可以考虑短线进场,仓位1/2左右。 ’),ALIGN2,colorDC143C;

  DRAWTEXT(TJTS1 and((CROSS(AVX,1) AND (V1 《= V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股形态尚可,但量能不足,必赢亚洲线上娱乐也未完全走强,可以短线参与,仓位1/3左右。 ’),ALIGN2,color0000FF;

  DRAWTEXT(TJTS1 and((CROSS(1,AVX) AND (V1 》= V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股形态变坏,但走势相对其它必赢亚洲线上娱乐尚可,重仓者减持大半,清仓者可以观望。 ’),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and((CROSS(1,AVX) AND (V1 《 V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 ’),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and((CROSS(1,AVX) AND (V1 》= V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股放量下跌,走势明显偏弱,离场观望。 ’),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and((CROSS(1,AVX) AND (V1 《 V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股缩量下跌,走势偏弱,离场观望。 ’),ALIGN2,color00FF00;

  DRAWTEXT(TJTS1 and((((AVX 》= 1) AND (ref(AVX,1) 》 0)) AND (V1 》= V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股形态良好,强势明显,量能充足,可以继续持有。 ’),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and((((AVX 》= 1) AND (ref(AVX,1) 》 0)) AND (V1 《 V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 ’),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and((((AVX 》= 1) AND (ref(AVX,1) 》 0)) AND (V1 》= V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 ’),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and((((AVX 》= 1) AND (ref(AVX,1) 》 0)) AND (V1 《 V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股走势趋弱,量能不足,减持大部分筹码。 ’),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS1 and((((AVX 《 1) AND (ref(AVX,1) 《 0)) AND (V1 》= V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股形态不佳,注意成交量的变化,但目前不适合参与。 ’),ALIGN2;

  DRAWTEXT(TJTS1 and((((AVX 《 1) AND (ref(AVX,1) 《 0)) AND (V1 《 V2)) AND (DSLX 》= DSLX1)) ,k2*0.99,‘该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 ’),ALIGN2;

  DRAWTEXT(TJTS1 and((((AVX 《 1) AND (ref(AVX,1) 《 0)) AND (V1 》= V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股有走强迹象,但量能不足,趋势不明,不适合操作。 ’),ALIGN2;

  DRAWTEXT(TJTS1 and((((AVX 《 1) AND (ref(AVX,1) 《 0)) AND (V1 《 V2)) AND (DSLX 《 DSLX1)) ,k2*0.99,‘该股走势太弱,没有参与价值。 ’),ALIGN2;

  DRAWTEXT(TJTS2 and(CROSS(AVX,1) AND (V1 》= V2)) ,k2*0.99,‘大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, ’),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and(CROSS(AVX,1) AND (V1 》= V2)) ,k2*0.98,‘ 如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 ’),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and(CROSS(AVX,1) AND (V1 《 V2)) ,k2*0.99,‘大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, ’),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and(CROSS(AVX,1) AND (V1 《 V2)) ,k2*0.98,‘ 可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 ’),ALIGN2,color0000FF;

  DRAWTEXT(TJTS2 and(CROSS(1,AVX) AND (V1 》= V2)) ,k2*0.99,‘大盘形态走坏,重仓者可以减去大部分仓位。 ’),ALIGN2,color00FF00;

  DRAWTEXT(TJTS2 and(CROSS(1,AVX) AND (V1 《 V2)) ,k2*0.99,‘大盘缩量调整,注意风险,短线清仓观望。 ’),ALIGN2,color00FF00;

  DRAWTEXT(TJTS2 and(((AVX 》= 1) AND (ref(AVX,1) 》 0)) AND (V1 》= V2)) ,k2*0.99,‘大盘走势良好,量能理想,可以继续持有强势股。 ’),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS2 and(((AVX 》= 1) AND (ref(AVX,1) 》 0)) AND (V1 《 V2)) ,k2*0.99,‘大盘形态良好,但量能稍显不足,随时准备减仓。 ’),ALIGN2,color00FFFF;

  DRAWTEXT(TJTS2 and(((AVX 《 1) AND (ref(AVX,1) 《 0)) AND (V1 》= V2)) ,k2*0.99,‘大盘趋势不明,注意成交量变化,目前不适宜进场。 ’),ALIGN2;

  DRAWTEXT(TJTS2 and(((AVX 《 1) AND (ref(AVX,1) 《 0)) AND (V1 《 V2)) ,k2*0.99,‘大盘趋势向下,量能萎缩,不适合进场。 ’),ALIGN2;

相关信息