大智慧精确风险指标公式


  RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  K1:=SMA(RSV,10,1);

  D1:=SMA(K1,5,1);

  KK:=INTPART(K1);

  DD:=INTPART(D1);

  TFXXS:=KK+DD;

  TGLD:=MOD(TFXXS,10);

  TGLXS:=(TFXXS-REF(TFXXS,1))*10;

  TYCFX:=TFXXS+TGLXS;

  {------【数值显示】}

  风险系数:TFXXS,PRECIS0,LINETHICK2,COLORYELLOW;

  乖离系数:TGLXS,PRECIS0,LINETHICK0,COLORGREEN;

  预测风险:TYCFX,PRECIS0,LINETHICK2,COLORCYAN;

  {级别拐点}

  VERTLINE(TGLXS》0 AND 100+TGLXS《TYCFX AND 100+REF(TGLXS,1)》=REF(TYCFX,1),1),PRECIS0,COLORYELLOW;

  VERTLINE(TGLXS《0 AND 100+TGLXS》=TYCFX AND 100+REF(TGLXS,1)《REF(TYCFX,1),1),PRECIS0,COLORYELLOW;

  {------【图解模板】}

  黄色筑底:TFXXS《=50,PRECIS0,LINETHICK0,COLORYELLOW;

  粉色上升:TFXXS《160 AND TFXXS》50 AND TFXXS》REF(TFXXS,1),PRECIS0,LINETHICK0,COLORMAGENTA;

  白色下降:TFXXS》50 AND TFXXS《160 AND TFXXS《REF(TFXXS,1),PRECIS0,LINETHICK0,COLORWHITE;

  蓝色铸顶持股先:TFXXS》=160,PRECIS0,LINETHICK0,COLORBLUE;

  {------【解盘分析】}

  卖出风险:TFXXS》=160,PRECIS0,LINETHICK0,COLORCYAN;

  追涨博弈:TFXXS》50 AND TFXXS《160 AND TFXXS》=REF(TFXXS,1) AND TFXXS《=100,PRECIS0,LINETHICK0,COLORRED;

  稳健持股:TFXXS》50 AND TFXXS《160 AND TFXXS》=REF(TFXXS,1) AND TFXXS》100,PRECIS0,LINETHICK0,COLORMAGENTA;

  盘跌减仓:TFXXS》50 AND TFXXS《160 AND TFXXS《REF(TFXXS,1) AND TFXXS》100,PRECIS0,LINETHICK0,COLORWHITE;

  杀跌空仓:TFXXS》50 AND TFXXS《160 AND TFXXS《REF(TFXXS,1) AND TFXXS《=100,PRECIS0,LINETHICK0,COLORGREEN;

  {乖离系数}

  STICKLINE(TGLXS》0,100,100+TGLXS,8,0),COLOR000088;

  STICKLINE(TGLXS》0,100,100+TGLXS,7,0),COLOR000099;

  STICKLINE(TGLXS》0,100,100+TGLXS,6,0),COLOR0000AA;

  STICKLINE(TGLXS》0,100,100+TGLXS,5,0),COLOR0000BB;

  STICKLINE(TGLXS》0,100,100+TGLXS,4,0),COLOR0000CC;

  STICKLINE(TGLXS》0,100,100+TGLXS,3,0),COLOR0000DD;

  STICKLINE(TGLXS》0,100,100+TGLXS,2,0),COLOR0000EE;

  STICKLINE(TGLXS》0,100,100+TGLXS,1,0),COLOR0000FF;

  STICKLINE(TGLXS《0,100,100+TGLXS,8,0),COLOR008800;

  STICKLINE(TGLXS《0,100,100+TGLXS,7,0),COLOR009900;

  STICKLINE(TGLXS《0,100,100+TGLXS,6,0),COLOR00AA00;

  STICKLINE(TGLXS《0,100,100+TGLXS,5,0),COLOR00BB00;

  STICKLINE(TGLXS《0,100,100+TGLXS,4,0),COLOR00CC00;

  STICKLINE(TGLXS《0,100,100+TGLXS,3,0),COLOR00DD00;

  STICKLINE(TGLXS《0,100,100+TGLXS,2,0),COLOR00EE00;

  STICKLINE(TGLXS《0,100,100+TGLXS,1,0),COLOR00FF00;

  STICKLINE(TGLXS=0 AND REF(TGLXS,1)》=0,100,100+TGLXS,8,0),COLORRED;

  STICKLINE(TGLXS=0 AND REF(TGLXS,1)《0,100,100+TGLXS,8,0),COLORGREEN;

  {风险系数

  PARTLINE(TFXXS《160 AND TFXXS》50,TFXXS),LINETHICK2,COLORMAGENTA;

  PARTLINE(TFXXS》50 AND TFXXS《160 AND TFXXS《REF(TFXXS,1),TFXXS),LINETHICK2,COLORWHITE;

  PARTLINE(TFXXS《=50,TFXXS),LINETHICK2,COLORYELLOW;

  PARTLINE(TFXXS》=160,TFXXS),LINETHICK2,COLORBLUE;}

  {风险系数}

  PARTLINE(TFXXS,TFXXS《160 AND TFXXS》50),PRECIS0,LINETHICK2,COLORFF66FF;

  PARTLINE(TFXXS,TFXXS》50 AND TFXXS《160 AND TFXXS《REF(TFXXS,1)),PRECIS0,LINETHICK2,COLORWHITE;

  PARTLINE(TFXXS,TFXXS《=50),PRECIS0,LINETHICK2,COLORYELLOW;

  PARTLINE(TFXXS,TFXXS》=160),PRECIS0,LINETHICK2,COLORBLUE;

  {预测风险}

  PARTLINE(TYCFX,C》0),COLORCYAN;

相关信息