通达信北沙画线主图指标免费源码(附公式说明)


  通达信北沙画线主图指标免费源码(附公式说明)

  说明 1、背离信号:通过价格和指标画线颜色的反差、能直观地看到背离信号; 2、形态信号:上升旗形、下降旗形、收敛三角、扩张三角、V形等等、将直观地展现在眼前; 3、注意与成交量的配合、形态再好、没有量的支持、结局往往不乐观;

  DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIF,9);

  MACD:=(DIF-DEA)*2,COLORSTICK;

  VA1:=HHVBARS(H,BARSLAST(MACD《0)+1);

  VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);

  JQG:=DRAWLINE(VA2,H,REF(VA2,1),REF(H,1),1),COLORGREEN,DOTLINE;{在价格画线}

  NOTEXT前高A:DRAWLINE(VA2,H,ISLASTBAR,REF(H,BARSLAST(VA2)),1),COLORWHITE,DOTLINE;

  DRAWNUMBER(ISLASTBAR,NOTEXT前高A,NOTEXT前高A),COLORWHITE;

  VA3:=LLVBARS(L,BARSLAST(MACD》0)+1);

  VA4:=CROSS(BACKSET(CROSS(MACD,0),REF(VA3,1)+2),0.5);

  NOTEXT前低A:DRAWLINE(VA4,L,ISLASTBAR,REF(L,BARSLAST(VA4)),1),COLORWHITE,DOTLINE;

  DRAWNUMBER(ISLASTBAR,NOTEXT前低A,NOTEXT前低A),COLORWHITE;

  基准:=CONST(SUM(VA2,0));

  前高4:=基准-4=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高3:=基准-3=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高2:=基准-2=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高1:=基准-1=SUM(VA2,0) AND VA2,COLORYELLOW,NODRAW;

  前高:=基准=SUM(VA2,0) AND VA2,COLORCYAN,NODRAW;

  距离G1:=BARSLAST(前高1);

  距离G2:=BARSLAST(前高2);

  距离G3:=BARSLAST(前高3);

  距离G4:=BARSLAST(前高4);

  NOTEXTG1:DRAWLINE(前高1,H,前高 AND H》=REF(H,距离G1),H,0),COLORYELLOW;

  NOTEXTG2:DRAWLINE(前高1,H,前高 AND H《REF(H,距离G1),H,0),COLORGREEN;

  NOTEXTG3:DRAWLINE(前高2,H,前高1 AND H》=REF(H,距离G2),H,0),COLORYELLOW;

  NOTEXTG4:DRAWLINE(前高2,H,前高1 AND H《REF(H,距离G2),H,0),COLORGREEN;

  NOTEXTG5:DRAWLINE(前高3,H,前高2 AND H》=REF(H,距离G3),H,0),COLORYELLOW;

  NOTEXTG6:DRAWLINE(前高3,H,前高2 AND H《REF(H,距离G3),H,0),COLORGREEN;

  NOTEXTG7:DRAWLINE(前高4,H,前高3 AND H》=REF(H,距离G4),H,0),COLORYELLOW;

  NOTEXTG8:DRAWLINE(前高4,H,前高3 AND H《REF(H,距离G4),H,0),COLORGREEN;

  基准2:=CONST(SUM(VA4,0));

  前低:=基准2=SUM(VA4,0) AND VA4;

  前低1:=基准2-1=SUM(VA4,0) AND VA4;

  前低2:=基准2-2=SUM(VA4,0) AND VA4;

  前低3:=基准2-3=SUM(VA4,0) AND VA4;

  前低4:=基准2-4=SUM(VA4,0) AND VA4;

  距离D1:=BARSLAST(前低1);

  距离D2:=BARSLAST(前低2);

  距离D3:=BARSLAST(前低3);

  距离D4:=BARSLAST(前低4);

  NOTEXTD1:DRAWLINE(前低1,L,前低 AND L》=REF(L,距离D1),L,0),COLORYELLOW;

  NOTEXTD2:DRAWLINE(前低1,L,前低 AND L《REF(L,距离D1),L,0),COLORGREEN;

  NOTEXTD3:DRAWLINE(前低2,L,前低1 AND L》=REF(L,距离D2),L,0),COLORYELLOW;

  NOTEXTD4:DRAWLINE(前低2,L,前低1 AND L《REF(L,距离D2),L,0),COLORGREEN;

  NOTEXTD5:DRAWLINE(前低3,L,前低2 AND L》=REF(L,距离D3),L,0),COLORYELLOW;

  NOTEXTD6:DRAWLINE(前低3,L,前低2 AND L《REF(L,距离D3),L,0),COLORGREEN;

  NOTEXTD7:DRAWLINE(前低4,L,前低3 AND L》=REF(L,距离D4),L,0),COLORYELLOW;

  NOTEXTD8:DRAWLINE(前低4,L,前低3 AND L《REF(L,距离D4),L,0),COLORGREEN;

  ZT:=REF(C,1)*1.1-C《0.01 AND H=C;{涨停}

  DT:=IF((REF(C,1)-C)*100/REF(C,1)》=(10-0.01*100/REF(C,1)) AND L=C,1,0);{跌停};

  BA:STICKLINE(ZT,OPEN,CLOSE,0.1,0),COLORYELLOW;

  BC:STICKLINE(DT,OPEN,CLOSE,0.1,0),COLORLIGREEN;

  DA:=YEAR AND MONTH AND DAY;

  AAA:=STRCAT(CON2STR(YEAR,0),‘年’);

  AAB:=STRCAT(CON2STR(MONTH,0),‘月’);

  AA33:=STRCAT(CON2STR(DAY,0),‘日’);

  AA4:=STRCAT(‘【’,IF(WEEKDAY=1,‘一’,IF(WEEKDAY=2,‘二’,IF(WEEKDAY=3,‘三 ’,IF(WEEKDAY=4,‘四’,IF(WEEKDAY=5,‘五’,IF(WEEKDAY=6,‘六’,‘日’)))))));

  AA:=STRCAT(STRCAT(STRCAT(AAA,AAB),STRCAT(AA33,AA4)),‘】’);

  SA:DRAWTEXT_FIX(DA,0,0,0,AA),COLORGREEN;