通达信涨停均价线主图指标公式


  均价:=AMOUNT/V/100;

  ZT:=REF(C,1)*1.1-C《0.01 AND H=C;{涨停}

  BA:STICKLINE(ZT,OPEN,CLOSE,0.1,0),COLORYELLOW;

  N:=30;{此数值可视需要调整}

  BL:=V=HHV(V,N) AND V》REF(V,1)*2;

  XGA:=ZT AND BL;

  TS:=BARSLAST(XGA);

  NOTEXTEE:IF(TS《=9,DRAWLINE(XGA,均价,REF(XGA,1),REF(均价,1),1),DRAWNULL),COLORYELLOW;

  DRAWNUMBER(ISLASTBAR,NOTEXTEE,NOTEXTEE),COLORYELLOW;

  NOTEXT2:IF(TS《=9,REF(C,TS),DRAWNULL),COLORGRAY;

  NOTEXT3:IF(TS《=9,REF(L,TS),DRAWNULL),COLORGRAY;

  ED:DRAWNUMBER(BETWEEN(TS,1,9),REF(L,TS),TS),COLORLIGRAY;