通达信俊俊出击+选股指标公式


  分段:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K2:=SMA(分段,4,1);

  D2:=SMA(K2,3,1);

  J2:=3*K2-2*D2;

  BB1:=EMA(J2,4);

  BB2:=REF(BB1,1);

  STICKLINE((BB1 《= BB2),106,100,8,0),COLOR56F709;

  STICKLINE((BB1 《= BB2),-1,0,8,0),COLOR2787F1;

  STICKLINE((BB1 《= BB2),-2,-1,8,0),COLOR1B7AEF;

  STICKLINE((BB1 《= BB2),-6,-2,8,0),COLOR0011E1;

  STICKLINE((BB1 《= BB2),100,0,8,0),COLORC0C0C0;

  STICKLINE((BB1 》=BB2 ),106,100,8,0 ),COLOR56F709;

  STICKLINE((BB1 》=BB2 ),-1,0,8,0 ),COLOR2787F1;

  STICKLINE((BB1 》=BB2 ),-2,-1,8,0 ),COLOR1B7AEF;

  STICKLINE((BB1 》=BB2 ),-6,-2,8,0 ),COLOR0011E1;

  STICKLINE((BB1 》=BB2 ),100,0,8,0 ),COLOR26C5F9;

  S1:=MA((2*C+H+L)/4,5);

  S2:=S1*(200-102)/100;

  S3:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));

  S4:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

  S5:=3*SMA(S4,3,1)-2*SMA(SMA(S4,3,1),3,1);

  S6:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));

  S7:=S2《S3&&S5》REF(S5,1)&&REF(S5,1)《REF(S5,2)&&S6《-100&&S6》REF(S6,1);

  俊俊出击:STICKLINE(S7,-2,80,2,0),COLOR0000FF;

  DRAWICON(俊俊出击,78,34);

  {

  选股公式:

  S1:=MA((2*C+H+L)/4,5);

  S2:=S1*(200-102)/100;

  S3:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));

  S4:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

  S5:=3*SMA(S4,3,1)-2*SMA(SMA(S4,3,1),3,1);

  S6:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));

  S7:S2《S3&&S5》REF(S5,1)&&REF(S5,1)《REF(S5,2)&&S6《-100&&S6》REF(S6,1);

  }