通达信强势股调整指标公式


  VAR1:=REF(MA(C,20),10);开:=O-VAR1;高:=H-VAR1;低:=L-VAR1;收:=C-VAR1;MID:=MA(C,20);

  UPPER:=MID+2*STD(C,20);LOWER:=MID-2*STD(C,20);V1:=(C-LOWER)/(UPPER-LOWER)*100;

  V2:=V1-EMA(V1,5);K1:=SUM(LLV(V2,4),4)/4;V3:=EMA(V2,64)*10;V4:=EMA(0.4*V2*(-1),3);

  V5:=-1*EMA(V2,39)*10;A:=V3》10;B:=V2》V4;D:=V5》10;E:=V3《=10 OR V2《=V4 OR V5《=10;

  STICKLINE(C,0,0,6,0), COLORYELLOW;

  STICKLINE(收》=开 AND E,高,低,0,0), COLORRED;

  STICKLINE(收》=开 AND E,收,开,3,0) ,COLORRED;

  STICKLINE(收《 开 AND E,高,低,0,0) ,COLORGREEN;

  STICKLINE(收《 开 AND E,收,开,3,0) ,COLORGREEN;

  STICKLINE(开》 收 AND A ,低,高,0,0),COLORFF0000;

  STICKLINE(开》 收 AND A ,收,开,3,0),COLORFF0000;

  STICKLINE(开《=收 AND A,低,高,0,0),COLORYELLOW;

  STICKLINE(开《=收 AND A,收,开,3,1),COLORYELLOW;

  STICKLINE(开》 收 AND B,低,高,0,0),COLORRED;

  STICKLINE(开》 收 AND B,收,开,3,0),COLORRED;

  STICKLINE(开《=收 AND B,低,高,0,0),COLORRED;

  STICKLINE(开《=收 AND B,收,开,3,1),COLORRED;

  STICKLINE(开》 收 AND D,低,高,0,0),COLORGREEN;

  STICKLINE(开》 收 AND D,收,开,3,0),COLORGREEN;

  STICKLINE(开《=收 AND D,收,开,3,1),COLORGREEN;