通达信牛股重生选股指标公式


  AA:=MA(CLOSE,1);

  AA1:=(LOW+HIGH+CLOSE)/3;

  AA2:= MA(AA1,5);

  BB:= HHV(AA2,10);

  BB1:= MA(AA1,5);

  BB2:=LLV(BB1,10);

  BB3:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);

  HD:=(HIGH - REF(HIGH,1));

  LD:=(REF(LOW,1) - LOW);

  HD1:=(SUM(IF(((HD 》 0) AND (HD 》 LD)),HD,0),5) );

  HD2:=SUM(IF(((LD 》 0) AND (LD 》 HD)),LD,0),5);

  HD3:=(((HD1 ) * 100) / BB3);

  LD1:=((HD2 * 100) / BB3);

  LD2:=(MA(((ABS((LD1 - HD3)) / (LD1 + HD3)) * 100),3));

  LD3:=((LD2 + REF(LD2,3)) / 2);

  DD:=“MACD.MACD”》0.04;

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  A:=CROSS(K,D);

  VAR1:=MA(LOW,1);

  VAR2:=MA(HIGH,2);

  VAR3:=MA(CLOSE,2);

  VAR4:=REF(VAR3,1);

  VAR5:=( IF(((LD2 》 88) AND (HD3 《 5.8)),80,0));

  牛股重生:IF(VAR5=0 AND C》O AND REF(VAR5,1)=80,80,0) AND DD AND A ;