通达信异动选股80%准确指标公式


  JJ:=(HIGH+LOW+CLOSE)/3;

  QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

  QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));

  QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));

  QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));

  QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));

  DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),COLOR00AAAA,LINETHICK;

  V2:=SMA(IF(C》=REF(C,1),DDX,-DDX/100),2,1);

  V5:=SMA(V2*240/FROMOPEN*0.9,5,1);

  DIFF:=(EMA(V2,12)-EMA(V2,26))*100/EMA(V2,26),COLORRED;

  DEA:=EMA(DIFF,9),COLORRED;

  DIF:=IF(DIFF《REF(DIFF,1),DIFF,DRAWNULL),COLORGREEN;

  ADEA:=IF(DEA《REF(DEA,1),DEA,DRAWNULL),COLORGREEN;

  V10:=SMA(V5,5,1);

  V20:=SMA(V10,5,1);

  {DRAWKLINE(V2*1.01*10,REF(V2,1)*10,REF(V2,1)*0.99*10,V2*10);}

  {STICKLINE(CURRBARSCOUNT=1 AND C》=REF(C,1),REF(V2,1),MAX(V2,V2*120/FROMOPEN*0.8),0,0),COLORLIMAGENTA;

  STICKLINE(CURRBARSCOUNT=1 AND C《REF(C,1),REF(V2,1),MIN(V2,V2*120/FROMOPEN*0.8),0,0),COLORLIGREEN;}

  {DRAWTEXT(DIFF《-200,DIFF,‘异动’),COLORMAGENTA;

  DRAWTEXT(CROSS(V2,REF(V2,1)*1.2) AND LONGCROSS(CLOSE,REF(C,1)*1.025,4) AND DDX/REF(MA(DDX,5),1)》2,REF(V2,1),‘★’),COLORMAGENTA;}

  {DRAWICON(CROSS(DIFF,DEA),DEA,1);}

  X:=(3*C+L+O+H)/6;

  多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)

  +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)

  +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+

  REF(X,20))/210,COLORFF00FF,LINETHICK2;

  注意:=ABS(DIFF)-ABS(REF(DIFF,1))》28 AND REF(多空线,1)《多空线 AND DIFF《0;

  {DRAWTEXT(注意,DIFF,‘注意’),COLORMAGENTA;}

  今日量:=V2*1.01-REF(V2,1)*0.99;{K线柱大小}

  昨日量:=REF(V2*1.01,1)-REF(REF(V2,1)*0.99,1);

  倍量:=今日量/ABS(昨日量);

  抓牛:REF(DIFF,1)《-200 AND CROSS(DIFF,DEA);