通达信三星战法选股指标公式


  M:=7;

  AAX:=MA((2*CLOSE+HIGH+LOW)/4,5);

  通道1:=AAX*100/100,LINETHICK2,COLORYELLOW;

  通道2:=AAX*(200-100)/100,LINETHICK2,COLORYELLOW;

  CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  DD:=DMA(CLOSE,CC);

  通道3:=(1+M/100)*DD,LINETHICK2,COLORRED;

  通道4:=(1-M/100)*DD,LINETHICK2,COLORRED;

  A1:=C/REF(C,1)《1.03;

  A2:=REF(C,1)/REF(C,2)《1.03;

  A3:=REF(C,2)/REF(C,3)《1.03;

  GG1:=REF(C,2)》REF(O,2) AND REF(C,1)》REF(O,1) AND NOT(C=12.23) AND C》O AND A1 AND A2 AND A3;

  GGG:GG1 AND C《(通道3+通道4)/2 AND C》REF(C,1);