通达信中短线MACD指标公式


  VAR1:=(C-MA(C,6))/MA(C,6)*100;

  VAR2:=(C-MA(C,24))/MA(C,24)*100;

  VAR3:=(C-MA(C,32))/MA(C,32)*100;

  VAR4:=(VAR1+VAR2+VAR3)/3;

  VAR5:=EMA(VAR4,5);

  VAR6:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;

  VAR7:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);

  VAR8:=VAR7《REF(VAR7,1) AND V》REF(V,1) AND C》REF(C,1);

  K:=EMA(VAR5,5)*4,NODRAW;

  D:EMA(K,5),NODRAW,COLOR38B0DE;

  J:K*3-D*2,NODRAW,COLORCC66FF;

  MACD:EMA(EMA(VAR1,5),5)*6,NODRAW,COLORWHITE;

  {DRAWBAND(J,RGB(238,238,6),K,RGB(256,150,60));}

  DRAWBAND(K,RGB(238,238,6),D,RGB(256,150,60));

  STICKLINE(MACD》0,0,MACD,1,0),COLORRED;

  STICKLINE(MACD》0 AND MACD《REF(MACD,1),0,MACD,1,0),COLORFFFF00;

  STICKLINE(MACD《0,0,MACD,1,0),COLORFF9900;

  STICKLINE(MACD《0 AND MACD》REF(MACD,1),0,MACD,1,0),COLORFF00FF;

  看多:IF(LLV(VAR6,3)《VAR6,-60,DRAWNULL),LINETHICK7,COLORRED;

  看空:IF(VAR6=LLV(VAR6,3),-60,DRAWNULL),LINETHICK7,COLORGREEN;

  中短线:IF(J》D,-50,DRAWNULL),LINETHICK7,COLORCC66FF;

  超短线:IF(VAR8》0,-40,DRAWNULL),LINETHICK7,COLORYELLOW;

  不定区:IF(J《D,-50,DRAWNULL),LINETHICK5,COLORFF9900;

  叶可人战区:IF(VAR8=0,-40,DRAWNULL),LINETHICK5,COLOR999999;