通达信机缘额指标公式


  VAR1:=REF(LOW,1);

  VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1)*100;

  VAR3:=EMA(IF(CLOSE*1.2,VAR2*13,VAR2/13),13);

  VAR4:=LLV(LOW,34);

  VAR5:=HHV(VAR3,34);

  VAR6:=IF(LLV(LOW,55),1,0);

  VAR7:=EMA(IF(LOW《=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;

  XL1:=MA(LOW,2)*0.96;

  XL2:=MA(LOW,26)*0.85;

  XL3:=REF(XL1,1)《XL2 AND REF(XL1,1)《XL1 AND REF(XL1,1)《REF(XL1,2);

  启动:IF(XL3,0,VAR7*3),COLORRED;

  XG:启动》25;

  RSV:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;

  K:=SMA(RSV,9,1);

  D:=SMA(K,3,1);

  趋势J1:3*K-2*D,COLORRED;

  趋势J2:EMA(K,3),LINETHICK1;

  IF(趋势J1》=REF(趋势J1,1),趋势J1,DRAWNULL),COLORRED,LINETHICK2;

  IF(趋势J1《 REF(趋势J1,1),趋势J1,DRAWNULL),COLORBLUE,LINETHICK2;

  BBIAS := (CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  抢反弹:= IF(CROSS(K,D) AND BBIAS《-6 AND D《16 AND CLOSE》REF(CLOSE,1),80,0),COLOR00FF00;

  DRAWICON(抢反弹=80,趋势J2-0.005,1);

  底部动态:EMA(IF(L《= LLV(L,40),SMA(ABS(L-REF(L,1)),40,1)/SMA(MAX(L-REF(L,1),0),40,1),0),3)*10,STICK,COLORRED,LINETHICK2;

  DRAWLINE(D》=HHV(D,21),D,D《=LLV(D,21),D,1),COLOR00FF00;

  V1:=AMOUNT/VOL/100;

  V2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

  V3:=SUM(AMOUNT,7)/V1/100;

  V4:=DMA(V2,VOL/V3);

  V5:=(CLOSE-V4)/V4*100;

  V6:=MA(V5,20)+STD(V5,20);

  BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

  STICKLINE(REF(BIAS21,1)》=5 AND CROSS(V6,V5) AND REF(“KDJ.J”(34,3,3),1)》80 AND REF(“KDJ.J”(9,3,3),1)》80,90,85,5,0),COLOR00FF00;