同花顺放空段持股段变盘点指标公式


  Var1:=MA(CLOSE,5);

  Var2:=MA(CLOSE,10);

  Var3:=MA(CLOSE,30);

  Var4:=MA(CLOSE,60);

  Var5:=EMA(COST(85),7);

  Var6:=EMA(COST(15),7);

  Var7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);

  Var8:=INTPART(Var7*100)/100;

  Var9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);

  VarA:=INTPART(Var9*100)/100;

  VarB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);

  VarC:=INTPART(VarB*100)/100;

  VarD:=EMA(CLOSE,5)-EMA(CLOSE,10);

  VarE:=EMA(CLOSE,5)-EMA(CLOSE,10);

  VarF:=EMA(VarD,9);

  放空段: IF(VarD》VarF,VarF,VarE),COLOR00FF00,LINETHICK2;

  持股段: IF(VarD《 VarF,VarF,VarE),COLORRED,LINETHICK2;

  Var10:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;

  Var11:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;

  Var12:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;

  Var13:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;

  Var14:=REF(VarF,1);

  Var15:=VarF;

  Var16:=Var15-Var14;

  Var17:=REF(VarD,1);

  Var18:=VarD;

  Var19:=Var18-Var17;

  Var1A:=OPEN;

  Var1B:=CLOSE;

  变盘点: IF(Var1A《=Var1 AND Var1A《=Var2 AND Var1A《=Var3 AND Var1B》=Var1 AND Var1B》=VarC AND Var16》0 AND Var19》0,0.5,0), STICK,COLORWHITE;

  Var1C:=IF(CROSS(VarD,VarF) AND VarD《0 AND VarF《-0.2 AND Var11》45 AND Var16》0,0.3,0);

  买进1: IF(Var1C,0.5,0),COLORYELLOW;

  DRAWICON(买进1,0.5,1);

  Var1D:=(2*CLOSE+HIGH+LOW)/4;

  Var1E:=LLV(LOW,34);

  Var1F:=HHV(HIGH,34);

  Var20:=EMA((Var1D-Var1E)/(Var1F-Var1E)*100,13);

  Var21:=EMA(0.667*REF(Var20,1)+0.333*Var20,2);

  Var22:=REF(CLOSE,1);

  Var23:=SMA(MAX(CLOSE-Var22,0),6,1)/SMA(ABS(CLOSE-Var22),6,1)*100;

  卖出: IF(CROSS(84,Var23),0.5,0),COLOR00FF00;

  DRAWICON(卖出,0.5,2);

  持仓:0,colorff00ff;

  空仓:0,colorgreen;

  持仓:STICKLINE(Var20》Var21,0,-0.02,10,1),COLORFF00FF;

  空仓:STICKLINE(Var20《 Var21,0,-0.02,10,1),COLORGREEN;