同花顺看盘炒个股指标公式


  同花顺看盘炒个股指标公式

  Var1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  Var2:=2*ABS(Var1);

  Var3:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))

  *100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))

  *100,20,1),15,1));

  Var4:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))

  *100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))

  *100,20,1),15,1));

  Var5:=(HIGH+LOW+CLOSE)/3;

  Var6:=(Var5-MA(Var5,10))/(0.015*AVEDEV(Var5,10));

  Var7:=(Var5-MA(Var5,30))/(0.015*AVEDEV(Var5,30));

  Var8:=IF(Var6》=150 AND Var6《200 AND Var7》=150 AND Var7《200,10,0);

  Var9:=IF(Var6《=-150 AND Var6》-200 AND Var7《=-150 AND Var7》-200,-10,Var8);

  VarA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  VarB:=100-ABS(VarA);

  VarC:=3*SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2

  *SMA(SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);

  VarD:=3*SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))

  *100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);

  VarE:=REF(LOW,1)*0.9;

  VarF:=LOW*0.9;

  Var10:=(VarF*VOL+VarE*(CAPITAL-VOL))/CAPITAL;

  Var11:=EMA(Var10,30);

  Var12:=Var11-CLOSE;

  Var13:=REF(CLOSE,1);

  Var14:=SMA(MAX(CLOSE-Var13,0),7,1)/SMA(ABS(CLOSE-Var13),7,1)*100;

  Var15:=SMA(MAX(CLOSE-Var13,0),13,1)/SMA(ABS(CLOSE-Var13),13,1)*100;

  Var16:=BARSCOUNT(CLOSE);

  Var17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

  Var18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;

  Var19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  Var1A:=(SMA(Var19,4,1)-50)*2;

  Var1B:=SMA(Var1A,3,1);

  Var1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

  Var1D:=SMA(Var1C,4,1);

  Var1E:=SMA(Var1D,3,1);

  Var1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

  Var20:=IF(Var17《=25 AND Var18《-95 AND Var1F》20 AND Var1B《-30 AND Var1E《30

  AND Var12》=-0.25 AND Var14《22 AND Var15《28 AND Var16》50,80,0);

  大趋势: Var3;

  顶线: IF(VarB《90,VarB,100);

  多方: IF(Var1》0,Var1,0), LINESTICK;

  空方: -IF(Var1《0,Var2,0), LINESTICK;

  抄底: Var20,colorred,linethick2;

  预警系统: (IF((Var7》=200 AND Var6》=150) OR CROSS(65,多方),15,IF(Var7《=-200

  AND Var6《=-150,-15,Var9))+65),colorcyan,LINETHICK2;

  STICKLINE(Var3《=REF(Var4,1),Var3,Var4,8,0),colorwhite;

  STICKLINE(Var3》REF(Var4,1),Var3,Var4,8,0),colorred;

  t1:=CLOSE》MA(CLOSE,20) AND MA(CLOSE,20)》=REF(MA(CLOSE,20),1);

  t2:=CLOSE《MA(CLOSE,20) AND MA(CLOSE,20)《REF(MA(CLOSE,20),1);

  t3:=多方》60 AND 预警系统》65 AND 顶线=100;

  t4:=多方》48 AND 预警系统》65 AND 顶线《100;

  t5:=空方《-38 AND 预警系统《65;

  t6:=抄底》50 AND 顶线《90;

  t7:=Var3》REF(Var4,1) AND VOL》REF(VOL,1) AND CLOSE》REF(CLOSE,1);

  t8:=Var3《=REF(Var4,1) AND CLOSE《REF(CLOSE,1) AND 预警系统=65 AND 抄底=0

  AND 空方》=REF(空方,1) AND VarC《REF(VarD,1);

  DRAWTEXT(t1 AND COUNT(t1,30)=1,10,‘上升通道!’),coloryellow;

  DRAWTEXT(t2 AND COUNT(t2,30)=1,55,‘下降通道!’),coloryellow;

  DRAWTEXT(t3 AND COUNT(t3,30)=1,55,‘上涨过急!’),coloryellow;

  DRAWTEXT(t4 AND COUNT(t4,30)=1,75,‘庄家出货!’),colorgreen;

  DRAWTEXT(t5 AND COUNT(t5,30)=1,50,‘有小反弹!’),colorwhite;

  DRAWTEXT(t6 AND COUNT(t6,30)=1,30,‘抢反弹!’),colorwhite;

  DRAWTEXT(t7 AND COUNT(t7,30)=1,-10,‘资金进场!’),colorwhite;

  DRAWTEXT(t8 AND COUNT(t8,30)=1,90,‘见顶回落!’),colorgreen;