同花顺黑马出动指标公式


  LC:=REF(CLOSE,1);

  RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

  TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

  HD:=(HIGH - REF(HIGH,1));

  LD:=(REF(LOW,1) - LOW);

  DMP:=SUM(IF(((HD 》 0) AND (HD 》 LD)),HD,0),10);

  DMM:=SUM(IF(((LD 》 0) AND (LD 》 HD)),LD,0),10);

  PDI:=((DMP * 100) / TR1);

  MDI:=((DMM * 100) / TR1);

  ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

  AV:=(RSI5 + ADX);

  DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

  0,COLORFF00FF;

  WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

  阶段底部:=(AV + NEWVOL);

  STICKLINE((阶段底部 《 0),0,-10,0.8,1),LINETHICK6,coloryellow;

  趋势线:=LLV(阶段底部,1),colorwhite,LINETHICK0;

  STICKLINE(CROSS(阶段底部,0),0,-10,0.8,1),LINETHICK6,colorred;

  STICKLINE((趋势线 》230 ),100,90,0.3,1),LINETHICK6,colorgreen;LOWV:=LLV(LOW,9);

  HIGHV:=HHV(HIGH,9);

  RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);

  K:EMA(RSV,3);

  D:MA(K,3);

  STICKLINE(K》D , K,D ,2.5,0),colorred,LINETHICK2;

  STICKLINE(D》K,K,D,2.5,0),colorgreen,LINETHICK2;

  逃顶线:90,colorgreen;

  中轴线: 50,colorred;

  抄底线:10,colorgreen;

  DRAWICON(CROSS(K,D) AND K《=50,12,1),colorred;

  DRAWICON(CROSS(D,K) AND K》=80,88,2),colorgreen;

  警戒:阶段底部 《 0,LINETHICK0,coloryellow;

  出击:CROSS(阶段底部,0),LINETHICK0,colorred