同花顺多方汇聚指标公式


  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  STICKLINE(DIFF》DEA,1,1.8,3,0),COLORFF9999;

  STICKLINE(DIFF《DEA,1,1.8,3,0),COLOR333333;

  MCDA金叉:=DIFF》DEA;

  ISLASTBAR = ISNULL(REFX(&CLOSE,1));

  DRAWTEXT(ISLASTBAR=1,1.4,‘.MACD’),COLORFFFFFF;

  RSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  STICKLINE(K》D,7,7.8,3,0),colorred;

  STICKLINE(K《D,7,7.8,3,0),COLOR333333;

  KDJ金叉:=K》D,;

  DRAWTEXT(ISLASTBAR=1,7.4,‘.KDJ’),COLORFFFFFF;

  LC:=REF(CLOSE,1);

  RSI1:=(SMA(MAX(CLOSE-LC,0),9,1))/(SMA(ABS(CLOSE-LC),9,1))*100;

  RSI2:=(SMA(MAX(CLOSE-LC,0),26,1))/(SMA(ABS(CLOSE-LC),26,1))*100;

  STICKLINE(RSI1》RSI2,3,3.8,3,0),COLOR6633CC;

  STICKLINE(RSI1《RSI2,3,3.8,3,0),COLOR333333;

  RSI金叉:=RSI1》RSI2;

  DRAWTEXT(ISLASTBAR=1,3.4,‘.RSI’),COLORFFFFFF;

  VARA1:=LLV(LOW,10);

  VARA2:=HHV(HIGH,25);

  趋势:= EMA((CLOSE-VARA1)/(VARA2-VARA1)*110,4),COLORFF00FF,LINETHICK5;

  STICKLINE(趋势》=REF(趋势,1),5,5.8,3,0),COLOR9933FF;

  STICKLINE(趋势《 REF(趋势,1),5,5.8,3,0),COLOR333333;

  顶底:=趋势》=REF(趋势,1);

  DRAWTEXT(ISLASTBAR=1,5.4,‘。顶底’),COLORFFFFFF;

  BBI:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;

  STICKLINE(CLOSE》BBI,4,4.8,3,0),COLORCC66FF;

  STICKLINE(CLOSE《BBI,4,4.8,3,0),COLOR333333;

  BBI金叉:=CLOSE》BBI;

  DRAWTEXT(ISLASTBAR=1,4.4,‘.BBI’),COLORFFFFFF;

  VAR1:=1;

  VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);

  VAR4:=LLV(LOW,5);

  VAR5:=HHV(HIGH,4);

  C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1);

  C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1);

  AA:=C1》=C2 ;

  BB:=C2》C1 ;

  STICKLINE(AA,6,6.8,3,0),COLOR0088FF;

  STICKLINE(BB,6,6.8,3,0),COLOR333333;

  抢反弹:=C1》=C2;

  DRAWTEXT(ISLASTBAR=1,6.4,‘。抢反弹’),COLORFFFFFF;

  VOLUME:=VOL;

  MAVOL1:=MA(VOLUME,5);

  MAVOL2:=MA(VOLUME,10);

  STICKLINE(MAVOL1》=MAVOL2,2,2.8,3,0),COLOR990066;

  STICKLINE (MAVOL1《MAVOL2,2,2.8,3,0),COLOR333333;

  成交量:MAVOL1》MAVOL2,POINTDOT;

  DRAWTEXT(ISLASTBAR=1,2.4,‘。成交量’),COLORFFFFFF;

  STICKLINE ( KDJ金叉 AND RSI金叉 AND 顶底 AND BBI金叉 AND 抢反弹 AND 成交量,0,0.8,3,0),COLORFF00FF;

  DRAWTEXT(ISLASTBAR=1,0.5,‘。操作’),COLORFFFFFF;