同花顺获利盘指标公式


  R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);

  K:=EMA(R,3);

  D:=EMA(K,3);

  一年12倍:20,colorred;

  陡峭度:=IF((BARSCOUNT(CLOSE) 》 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);

  N:=IF((陡峭度 》 0.35),6,65);

  VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))));

  VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100);

  获利盘:=(WINNER(CLOSE))*(100);

  获利线:=FORCAST(获利盘,7);

  线:=(FORCAST(VAR1A,7));

  满仓:=((线 》 REF(线,1)) AND (线 《 25) AND (COUNT((线 》 REF(线,1)),5) = 1) AND IF((N = 6),(获利盘 《 60),(获利盘 《 40)) AND (COUNT((获利线 》 20),20) 》 0))*(40);

  STICKLINE(满仓,0,40,5,0),Color008000;

  DRAWTEXT(满仓,45,‘满仓’),Color008000;

  轻仓:=IF((获利盘 》= 60) AND (线 》 REF(线,1)) AND (REF(线,1) 《 20) AND (线 《 40) AND (COUNT((线 》 REF(线,1)),5) = 1) AND (REF(N,1) = 6),1,0);

  STICKLINE(轻仓,20,D,4,1),ColorFF00FF;

  DRAWTEXT(轻仓,45,‘轻仓’),ColorFF00FF;

  出击:=CROSS(线,20) AND IF((COUNT(CROSS(K,D),3) = 1) AND (D 《 40),1,(线 》 D) OR (K 》 D) AND (D 《 60)) AND IF((N = 6),(获利盘 《 70),(获利盘 《 40)) AND (COUNT((获利线 》 20),20) 》 0);

  STICKLINE(出击,0,50,3,1),Color44BB00;

  DRAWTEXT(出击,55,‘出击’),colorred;

  进1:=CROSS(线,D) AND (D 》 30) AND (D 》 REF(D,1)) AND (D 《 80);

  进2:=CROSS(线,获利线) AND (D 》 30) AND (获利线 》 25) AND (D 》 REF(D,1));

  低进:=IF(进1 AND (D 》 获利线),进2,进1);

  DRAWTEXT(低进,30,‘低进’),ColorFF0000;

  STICKLINE(低进,20,30,3,1),Color000080;

  DRAWTEXT(进2,50,‘高进’),Color800080;

  STICKLINE(进2,30,50,3,1),coloryellow;

  狂喜:=(30)*(CROSS(VAR1,(-2)));

  STICKLINE(狂喜,0,20,3,1),coloryellow;

  DRAWTEXT(狂喜,(-5),‘要涨停’),coloryellow;

  狂喜过望:=(50)*((VAR1 = 0));

  恐慌:(-20)*((VAR1 《 (-94))),ColorC1C1C1;

  STICKLINE(恐慌,0,(-20),5,0),ColorC1C1C1;

  DRAWTEXT(恐慌,(-25),‘恐慌’),ColorC1C1C1;

  极度恐慌:(-40)*((VAR1 = (-100))),Color800000;

  STICKLINE(极度恐慌,0,(-40),7,1),Color800000;

  DRAWTEXT(极度恐慌,(-45),‘极度恐慌’),Color800000;

  半仓:=(30)*(CROSS(VAR1,(-94)) AND (COUNT(恐慌,5) 》 0) AND (N = REF(N,1)) AND IF((N = 6),(获利盘 《 60),(获利盘 《 40)) AND (COUNT((获利线 》 20),20) 》 0));

  STICKLINE(半仓,0,30,4,1),ColorFFFF00;

  DRAWTEXT(半仓,35,‘半仓’),ColorFFFF00;

  加仓:=(30)*(CROSS(K,20) AND (COUNT(半仓,5) 》 0));

  STICKLINE(加仓,0,20,6,1),Color808080;

  DRAWTEXT(加仓,25,‘加仓’),Color808080;

  背离:=(COUNT(恐慌,2) 》 0) AND (CLOSE 《 REF(CLOSE,1)) AND (VAR1 》 REF(VAR1,1));

  DRAWICON(背离,0,1),ColorFFFFFF;

  (-55),colorred;