突破高低点均线变色源码


突破高低点均线变色源码
内容:
原始的图(MA高中低.JPG)源代码如下:

HH:MA(REF(H,1),N);
LL:MA(REF(L,1),N);

N=10;

想要实现基本构想:

(1)如果收盘价C第一次大于HH,则用红线画出HH;并且在HH线上标识即时HH值。同时LL线显示到此为止。

(2)直到收盘价C第一次小于LL,则用绿线画出LL;并且在LL线下标识即时LL值。同时HH线到此为止。

源码 仅供参考 参数(N, 10 , 0 , 999):
HH:=MA(REF(H,1),N);
LL:=MA(REF(L,1),N);//程序化交易
A:=REFX(HH-REF(HH,1),1);
B:=REFX(LL-REF(LL,1),1);
DRAWSL(C<HH,HH,A,1,0,COLORRED);
DRAWSL(C>LL,LL,B,1,0,COLORGREEN);
DRAWNUMBER(CROSS(C,HH),HH,HH,1,COLORYELLOW);
DRAWNUMBER(CROSS(LL,C),LL,LL,1,COLORMAGENTA);