文华TR指标交易模型源码


参数:N{10,0,9999}

源码:

TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
R:=MA(TR,10);
Z:=REF(HHV(HIGH,N),1);
D:=REF(LLV(LOW,N),1);
Z-CLOSE>=2*R,SPK;
CLOSE-D>=2*R,BPK;
AUTOFILTER;//赢顺软件可去掉

=====================================

源码解析

TR赋值:(最高价-最低价)和昨收-最高价的绝对值的较大值和昨收-最低价的绝对值的较大值
R赋值:真实波幅的10日简单移动平均
Z赋值:昨日N日内最高价的最高值
D赋值:昨日N日内最低价的最低值
Z-收盘价>=2*R,SPK
收盘价-D>=2*R,BPK