文华优化版均线指标源码


优化版均线

咨询内容:
//{价格中枢-日内多空认同}

AS:=(C*3+O+H+L)/6;

XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382; //{回调认同}

HLX:=EMA(HHV(XJ,3),15);

LLX:=EMA(LLV(XJ,3),15);

CH=CROSS(XJ,HLX);

CL:=CROSS(LLX,XJ);

CHH:=BARSLAST(CH);

CLL:=BARSLAST(CL);

YF1:=(CHHCLL OR CL) AND NOT(CH);

TF:=IF(YF1,LLX,HLX);

TFB:=(HLX+LLX)/2;

XJK:=SMA(EMA(XJ,3),3,1);

ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4;

SH:=EMA(ZWSH,21);

ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4;

SL:=EMA(ZWSL,21);

SCH:=CROSS(XJ,SH);

SCL:=CROSS(SL,XJ);

SHH:=BARSLAST(SCH);

SLL:=BARSLAST(SCL);

SF1:=(SHHSLL OR SCL) AND NOT(SCH);

TFS:=IF(SF1,SL,SH); TFBS:=(SL+SH)/2; //{回调认同}

FILLRGN(TFB,TFS,XJ>TFS,COLOR400040);

FILLRGN(TFB,TFS,XJTF,COLOR000060);

FILLRGN(TFB,TF,XJ=OPEN) AND XJ>=TFS;

KX2:=(CLOSE=TFS;

KX3:=(CLOSE>=OPEN) AND XJ=TFS AND XJ=TF)) AND CLOSE>=OPEN;

KX6:=((XJ>=TFS AND XJ=TF)) AND CLOSE

文华技术人员:
您这句 模型中没有CHHCLL这个定义,您看是不是写错了。

CHHCLL OR CL) AND NOT(CH);

文华客服: //{价格中枢-日内多空认同}
AS:=(C*3+O+H+L)/6; XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382; //{回调认同} HLX:=EMA(HHV(XJ,3),15); LLX:=EMA(LLV(XJ,3),15); CH=CROSS(XJ,HLX); CL:=CROSS(LLX,XJ); CHH:=BARSLAST(CH); CLL:=BARSLAST(CL); YF1:=(CHHCLL OR CL) AND NOT(CH); TF:=IF(YF1,LLX,HLX); TFB:=(HLX+LLX)/2; XJK:=SMA(EMA(XJ,3),3,1); ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4; SH:=EMA(ZWSH,21); ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4; SL:=EMA(ZWSL,21); SCH:=CROSS(XJ,SH);SCL:=CROSS(SL,XJ); SHH:=BARSLAST(SCH);SLL:=BARSLAST(SCL); SF1:=(SHHSLL OR SCL) AND NOT(SCH); TFS:=IF(SF1,SL,SH); TFBS:=(SL+SH)/2; //{回调认同} FILLRGN(TFB,TFS,XJ>TFS,COLOR400040); FILLRGN(TFB,TFS,XJTF,COLOR000060); FILLRGN(TFB,TF,XJ=OPEN) AND XJ>=TFS; KX2:=(CLOSE=TFS; KX3:=(CLOSE>=OPEN) AND XJ=TFS AND XJ=TF)) AND CLOSE>=OPEN; KX6:=((XJ>=TFS AND XJ=TF)) AND CLOSE
网友回复: YF1:=(CHH小于CLL OR CH) AND NOT(CL); YF2:=(CHH大于CLL OR CL) AND NOT(CH);
网友回复:
为您修改如下:

AS:=(C*3+O+H+L)/6;

XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382; //{回调认同}

HLX:=EMA(HHV(XJ,3),15);

LLX:=EMA(LLV(XJ,3),15);

CH:=CROSS(XJ,HLX);

CL:=CROSS(LLX,XJ);

CHH:=BARSLAST(CH);

CLL:=BARSLAST(CL);

YF1:=(CHH<CLL OR CL) AND NOT(CH);

TF:=IFELSE(YF1,LLX,HLX);

TFB:=(HLX+LLX)/2;

XJK:=SMA(EMA(XJ,3),3,1);

ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4;

SH:=EMA(ZWSH,21);

ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4;

SL:=EMA(ZWSL,21);

SCH:=CROSS(XJ,SH);

SCL:=CROSS(SL,XJ);

SHH:=BARSLAST(SCH);

SLL:=BARSLAST(SCL);

SF1:=(SHH>SLL OR SCL) AND NOT(SCH);

TFS:=IFELSE(SF1,SL,SH); TFBS:=(SL+SH)/2; //{回调认同}

FILLRGN(TFB,TFS,XJ>TFS,COLORRED);

FILLRGN(TFB,TFS,XJ<TFS,COLORBLUE);

FILLRGN(TFB,TF,XJ=OPEN,COLORGREEN) AND XJ>=TFS;

KX2:=CLOSE=TFS;

KX3:=(CLOSE>=OPEN) AND XJ=TFS AND XJ=TF AND CLOSE>=OPEN;

KX6:=((XJ>=TFS AND XJ=TF)) AND CLOSE;

模型仅供参考;