KDJ MACD指标模型源码


咨询内容:
老师,我想写个指标,想法是这样的:

1、KD指标里面K>D时候,多状态(不是多信号)K<D时候是空状态(也不是空信号);

2、MACD指标里面DIFF>DEA时候,多状态,DIFF<DEA空状态;

3、两个指标都是多状态,开多,反之开空;

4、两个指标一个是多状态,一个是空状态,平仓(平多或者平空,有什么平什么);

请问如上思路能实现吗?

赢顺技术人员:
为您编写如下:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;//收盘价与N周期最高值做差,N周期最高值与N周期最低值做差,两差之间做比值。
K:SMA(RSV,3,1);//RSV的移动平均值
D:SMA(K,3,1);//K的移动平均值
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);//短周期与长周期的收盘价的指数平滑移动平均值做差。
DEA : EMA(DIFF,9);//DIFF的M个周期指数平滑移动平均
K>D&&DIFF>DEA,BK;
K<D&&DIFF<DEA,SK;
(K>D&&DIFF<DEA)||(K<D&&DIFF>DEA),SP;
(K>D&&DIFF<DEA)||(K<D&&DIFF>DEA),BP;
AUTOFILTER;

模型仅供参考;