ATR资金管理模型源码


ATR资金管理

//ATR资金管理模型
A:=10T/手;//合约单位
TR := MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:= DMA(TR,0.05);
SS:=INTPART(MONEY/(ATR*A));//模型中没有四舍五入函数,以取整代替。
DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA := EMA(DIFF,M);
CROSS(DIFF,DEA),BPK(SS);
CROSS(DEA,DIFF),SPK(SS);